Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: what is this worms??

  1. #11
    Frugal Fishkeeper Site Supporter
    Join Date
    Nov 2012
    Location
    Fort Worth, TX
    Posts
    1,412

    Default

    planaria they were then. I had removed all my assassin snails but continued to find a couple of dead shrimp a day in my tank, saw one baby shrimp, then I didn't. I may have started with a couple of planaria in a moss ball maybe? but they were literally free-swimming in the tank this evening, as well as in the substrate. The shrimp have been avoiding the bottom of the tank for a couple of months. I found no planaria in my moss balls when I soaked them in hot tap water, nor did I find any in the plant or substrate it's potted in. I moved the shrimp to a pitcher, tossed everything else and bleached everything but the sponge for the sponge filter and the plants. Rinsed well, they'd had a big water change recently so they should adjust to pH and I stole a gallon of water from an established tank. Shrimp lived at introduction, will see how they do tomorrow. No flat triangle head, just skinny and many, reckon I overfed for the last year. I have seen the error of my ways.

    I will get some "No planaria" if the shrimp live through the big cleanup
    Gee, I get a sig file?



  2. #12

    Default

    The biggest reason that you get them is dirty water. As said before probably from over feeding. The best way to get rid of them is to start daily water changes and feed properly. Remember I am a discus guy so large daily water changes are our thing.....but if you do that for a while the problem will go away. Also everything else in your tank will benefit.

    -john



  3. #13
    Frugal Fishkeeper Site Supporter
    Join Date
    Nov 2012
    Location
    Fort Worth, TX
    Posts
    1,412

    Default

    Tank went close to a year without a water change, 2018 was a year of grief, will try to do better
    Gee, I get a sig file?



  4. #14
    Frugal Fishkeeper Site Supporter
    Join Date
    Nov 2012
    Location
    Fort Worth, TX
    Posts
    1,412

    Default

    Lost 2 more shrimp, but seems to be stabilizing. not feeding as I am worried about an ammonia or nitrite spike. I gave them a betta pellet yesterday.
    Gee, I get a sig file?



  5. #15
    Frugal Fishkeeper Site Supporter
    Join Date
    Nov 2012
    Location
    Fort Worth, TX
    Posts
    1,412

    Default

    And I am not losing shrimp anymore and one of my mama shrimp has white eggs visibly rolling around on her "belly".

    - - - Updated - - -

    I boiled the gravel from the shrimp tank and found no more worms in filter, moss balls, anything. I think the worms were killing the shrimp
    Gee, I get a sig file?



Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •